杭电ACM部分题答案

1000A + B Problem
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158161    Accepted Submission(s): 50186
Problem Description
Calculate A + B.
 
Input
Each line will contain two integers A and B. Process to end of file.
 
Output
For each case, output A + B in one line.
 
Sample Input
1 1
 
Sample Output
2
 
Author
HDOJ
 
Statistic | Submit | Discuss | Note
#include<stdio.h>
int main()
{
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF)
        printf("%d\n",a+b);
}
1002A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84367    Accepted Submission(s): 15966
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the n
umber of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 111111*********1110
 
Author
Ignatius.L
 
Statistic | Submit | Discuss | Note
#include <stdio.h>
#include <string.h>
int main(){
    char str1[1001], str2[1001];
    int t, i, len_str1, len_str2, len_max, num = 1, k;
    scanf("%d", &t);新世纪饮食
    getchar();
王冶平简历
    while(t--){
        int a[1001] = {0}, b[大丈夫私房钱1001] = {0}, c[1001] = {0};
        scanf("%s", str1);
        len_str1 = strlen(str1);
        for(i = 0; i <= len_str1 - 1; ++i)
            a[i] = str1[len_str1 - 1 - i] - '0';
        scanf("%s",str2);
        len_str2 =  strlen(str2);
        for(i = 0; i <= len_str2 - 1; ++i)
            b[i] = str2[len_str2 -摩擦片 1 - i] - '0';
        if(len_str1 > len_str2)
            len_max = len_str1;
        else
            len_max = len_str2;
        k = 0;
        for(i = 0; i <= len_max - 1; ++i){
            c[i] = (a[i] + b[i] + k) % 10;
            k = (a[i] + b[i] + k) / 10;
        }
        if(k != 0)
        c[len_max] = 1;
        printf("Case %d:\n", num);
        num++;
        printf("%s + %s = ", str1, str2);
        if(c[len_max] == 1)
            printf("1");
        for(i = len_max - 1; i >= 0; --i){
            printf("%d", c[i]);
        }
        printf(美能达相机维修"\n");
        if(t >= 1)
            printf("\n");
    }
    return 0;
}
1005Number Sequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44346    Accepted Submission(s): 9722
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5
 
Author
CHEN, Shunbao
 
Source
ZJCPC2004
 
Recommend
JGShining
 
Statistic | Submit | Discuss | Note
#include<stdio.h>
int f[200];
int main()
{
    int aalp,b,n,i;

本文发布于:2024-09-21 10:52:37,感谢您对本站的认可!

本文链接:https://www.17tex.com/xueshu/471019.html

版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。

标签:私房钱   大丈夫
留言与评论(共有 0 条评论)
   
验证码:
Copyright ©2019-2024 Comsenz Inc.Powered by © 易纺专利技术学习网 豫ICP备2022007602号 豫公网安备41160202000603 站长QQ:729038198 关于我们 投诉建议