杭电ACM试题答案

【杭电ACM1000】
A + B Problem
Problem Description
Calculate A + B.
Input
Each line will contain two integers A and B. Process to end of file.
Output
For each case, output A + B in one line.
Sample Input
1 1
Sample Output
2
# include <stdio.h>
int main()
{水之镜
    int a, b;
    while(scanf("%d%d", &a, &b)!=EOF)
    printf("%d\n", a+b);
    return 0;
}
【杭电ACM1001】
嘉陵街火Sum Problem
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
# include <stdio.h>
int main()
{
    int n, i, sum = 0;
    while(scanf("%d", &n)!=EOF)
    {
    for(i=1; i<=n; ++i)
        sum = sum + i;
    printf("%d\n\n", sum);
    sum = 0;
    }
    return 0;
}
【杭电ACM1002】
A + B Problem II
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
董家天主堂
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice
that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 111111*********1110
#include<stdio.h>
#include<string.h>
int shu(char a)
{
    return (a-'0');
}
int main(){
    char a[1000],b[1000];
    int num[1001];
    int n,i,j=1,al,bl,k,t;
    scanf("%d",&n);
    while(n--)
    {
      getchar();
        if(j!=1)
            printf("\n");
      scanf("%s",a);
      al=strlen(a);
      scanf("%s",b);
陕西金号
      bl=strlen(b);
      k=(al>bl)?al:bl;
      for(i=0;i<=k;i++)
      num[i]=0;
      t=k;
变异系数cv
      for(k;al>0&&bl>0;k--)
      {
          num[k]+=shu(a[--al])+shu(b[--bl]);
          if(num[k]/10)
居里夫人的女儿
          {
              num[k-1]++;
              num[k]%=10;
          }
      }
      while(al>0)
      {
            num[k--]+=shu(a[--al]);
            if(num[k+1]/10)
          {
              num[k]++;
              num[k+1]%=10;
          }
      }
      while(bl>0)
      {
            num[k--]+=shu(b[--bl]);
            if(num[k+1]/10)
          {
              num[k]++;
              num[k+1]%=10;
          }
      }
      printf("Case %d:\n",j++);
      printf("%s + %s = ",a,b);
      for(i=0;i<=t;i++)
      {
          if(i==0&&num[i]==0)
          i++;
          printf("%d",num[i]);
      }
      printf("\n");
  }
  return 0;
}

本文发布于:2024-09-20 20:34:16,感谢您对本站的认可!

本文链接:https://www.17tex.com/xueshu/471012.html

版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。

标签:董家   陕西   天主堂   金号
留言与评论(共有 0 条评论)
   
验证码:
Copyright ©2019-2024 Comsenz Inc.Powered by © 易纺专利技术学习网 豫ICP备2022007602号 豫公网安备41160202000603 站长QQ:729038198 关于我们 投诉建议